Qualtrics Degraded Performance
Incident Report for UAA IT Services
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 10:55 AKDT
Investigating
Our automated systems have detected an issue with Qualtrics. Technicians have been notified and are monitoring the incident.
Posted Aug 30, 2020 - 04:10 AKDT
This incident affected: Software & Applications (Qualtrics).