Qualtrics Degraded Performance
Incident Report for UAA IT Services
Resolved
The incident has been resolved.
Posted Jul 22, 2021 - 08:50 AKDT
Investigating
Our automated systems have detected an issue with Qualtrics. Technicians have been notified and are monitoring the incident.
Posted Jul 22, 2021 - 08:45 AKDT
This incident affected: Software & Applications (Qualtrics).