Pharos Printing Outage
Incident Report for UAA IT Services
Resolved
This incident has been resolved.
Posted Oct 12, 2022 - 11:30 AKDT
Identified
We have determined the issue and are working on resolving it.
Posted Sep 30, 2022 - 16:30 AKDT
Investigating
Pharos printing is down. We are looking into it and will post here as soon as we know more.
Posted Sep 30, 2022 - 14:45 AKDT