Prince William Sound College Network and Phone outage
Incident Report for UAA IT Services
Resolved
UAA IT Services Engineers report the issue was resolved by the Internet provider. Thank you for your patience.
Posted Sep 25, 2020 - 11:26 AKDT
Investigating
We are currently investigating an network and telephone outage at Prince William Sound College. We will provide an update at 11:25 AM.
Posted Sep 25, 2020 - 11:15 AKDT
This incident affected: UAA Network and Telephony.