Partial Outage with the Technical Support Center Line

Incident Report for UAA IT Services

Resolved

This issue has been resolved. Customers can now reach our Technical Support Center's (TSC) line, 907-786-4646.

We’re sorry for the delays this may have caused.
Posted Apr 24, 2026 - 10:12 AKDT

Update

We have no new information at this time, but we appreciate your patience.

We will post an update tomorrow morning at 9 AM and as new information becomes available.
Posted Apr 23, 2026 - 15:58 AKDT

Investigating

We’re currently experiencing an issue where some customers are unable to reach our Technical Support Center's (TSC) line, 907-786-4646.

UAA IT Services is working to identify the root cause and implement a solution.

So far, customers on AT&T and Verizon are mostly affected and may not be able to call 907-786-4646.

Next update at 1:30 P.M.
Posted Apr 23, 2026 - 12:32 AKDT
This incident affected: UAA Network and Telephony.