Power Outage Event Fairbanks Area
Incident Report for UAA IT Services
Resolved
Power for the UAF Main Campus and UA IT services are up and operational
Posted Jul 21, 2022 - 16:30 AKDT
Investigating
A power outage occurred in the Fairbanks area impacting UA main campus and the Fairbanks area. We have technicians investigating.
Posted Jul 21, 2022 - 14:45 AKDT