Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 19, 2026 - 23:00 AKDT
Scheduled
What: UAA IT Services will be performing maintenance on the UAA Core Network beginning Sunday, April 19 at 11:00 PM through Monday, April 20 at 2:00 AM.
Why: To improve network reliability and performance.
Result: A brief (less than 1 min) internet outage is expected during the maintenance period for the entire UAA network, including community campuses.
Any Issues: If you experience issues connecting to the UAA Network after the maintenance is completed, don't hesitate to get in touch with the Technical Support Center.
Posted Apr 15, 2026 - 09:26 AKDT
This scheduled maintenance affected: UAA Network and Telephony.