Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 06:15 AKDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 06:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted May 20, 2025 - 05:15 AKDT
Scheduled
ACS will perform maintenance on the Fairbanks to Seattle Internet2 circuit. This work is necessary to maintain and manage this critical system. We expect there to be a potential 15 minute disruption as services failover to the back up paths and reconverge to normal paths after the completion of the work.