Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 04, 2025 - 19:45 AKDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 04, 2025 - 19:30 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Apr 04, 2025 - 18:45 AKDT
Scheduled
We plan to upgrade the network switches for the Signer's Hall building. The work will include wireless and wired network outages for the duration of our scheduled time.