The issue with network performance degradation affecting KRC, KBC, and MSC has been resolved.
We’re sorry for any issues this may have caused.
Posted Dec 19, 2025 - 12:32 AKST
Monitoring
Our internet service provider deployed a resolution to the performance degradation.
Users should now see their network performance back to normal.
We’re monitoring to ensure the network performance remains stable.
Next update will be at 9 AM tomorrow.
Posted Dec 18, 2025 - 10:32 AKST
Update
Network performance is improving but not yet fully resolved
The Vendor found a bad fiber connection in their network and routed around it. They will be doing tests at our sites. Users may experience short interruptions while they validate the circuits.
Posted Dec 17, 2025 - 13:48 AKST
Identified
We are currently experiencing network performance degradation affecting KRC, KBC, and MSC locations. Network circuits at these sites are operating at significantly reduced bandwidth (approximately 5 Mbps).
Our engineering team is actively investigating the issue and is working with our service provider to identify the root cause and restore normal performance. At this time, no estimated time to resolution is available.
Further updates will be posted as more information becomes available.
Posted Dec 17, 2025 - 09:00 AKST
This incident affected: UAA Network and Telephony.