Canvas Outage

Incident Report for UAA IT Services

Update

The most recent update from Instructure is:

Instructure has placed Canvas, Canvas Beta and Canvas Test in maintenance mode. We anticipate being up soon, and will provide updates as soon as possible

You can continue to view real-time updates as they make them at https://status.instructure.com/incidents/m88d7ymwpzpy and we will continue to make updates starting at the beginning of the business day (8:00AM) tomorrow.

Thank you again for your patience as we follow the resolution of this issue!
Posted May 07, 2026 - 17:30 AKDT

Identified

Instructure, the vendor hosting Canvas, is now reporting on this outage, and their real-time updates can be viewed here: https://status.instructure.com/incidents/m88d7ymwpzpy

We will continue to make updates as new information becomes available, as well as at the end of the business day (5:00PM) today.
Thank you again for your time and patience!
Posted May 07, 2026 - 14:30 AKDT

Investigating

We have received reports that Canvas appears to be under maintenance by the vendor; the NTS Systems Engineering team is currently investigating, and we will be making updates at 3-hour intervals.

Thank you for your patience during the resolution of this issue!
Posted May 07, 2026 - 13:00 AKDT