UAF Chukchi Campus Internet Outage
Incident Report for UAA IT Services
Resolved
This incident has been resolved.
Posted Jul 18, 2022 - 10:00 AKDT
Monitoring
Chukchi Campus has been restored and will be monitored for 24hrs.
Posted Jul 14, 2022 - 12:00 AKDT
Investigating
We have been notified that the internet at the Chukchi Campus in Kotzebue is currently down. We are currently investigating.
Posted Jul 14, 2022 - 10:00 AKDT