Some Gmail users may see delay in sending the emails

Incident Report for UAA IT Services

Resolved

Google has resolved the email issue.
Posted Dec 01, 2023 - 11:40 AKST

Investigating

Google is reporting an incident affecting Gmail. You may see delays sending emails. If you experience the issue, you can retry sending the email.
Posted Dec 01, 2023 - 11:37 AKST
This incident affected: G Suite @ UA (Google Apps Gmail).