Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2026 - 20:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Jun 23, 2026 - 19:15 AKDT
Scheduled
As part of an industry-wide Microsoft security update, the University is standardizing how its central authentication system (Active Directory) handles encryption. During this maintenance we will bring all domain controllers, the servers that verify usernames and passwords, into a single, consistent configuration. This is a preparatory step that lets us safely complete the move to stronger encryption ahead of a Microsoft deadline later this year.
The work will be performed in a scheduled maintenance window and involves restarting the authentication servers one at a time. Because the remaining servers continue handling logins throughout, no disruption to signing in, email, or other services is expected, and no action is required by anyone.
Posted Jun 23, 2026 - 16:16 AKDT
This scheduled maintenance affected: Accounts & Accesses.