Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 04, 2025 - 04:15 AKST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 04, 2025 - 04:00 AKST
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Dec 04, 2025 - 03:15 AKST
Scheduled
One service interruption of approximately 5-10 minutes is anticipated during the maintenance window. Alaska Communications will be performing maintenance to move University of Alaska 40G circuit between Fairbanks and Seattle, from AKORN to Northstar.