Print.alaska.edu Outage

Incident Report for UAA IT Services

Resolved

The OIT PAWS team has resolved the issue with the print.alaska.edu service, and NTS TSS has confirmed the fix to be stable.

Please report any continued issues with this service to your campus's IT helpdesk, and thank you again for your patience during the resolution of this issue!
Posted Feb 26, 2026 - 15:45 AKST

Monitoring

OIT PAWS has implemented a fix to the print.alaska.edu site, which is being monitored for effectiveness and stability.

Thank you again for your patience during the resolution of this issue! You can expect further updates at the end of the business day (5:00PM) or as new information becomes available.
Posted Feb 26, 2026 - 15:00 AKST

Investigating

We have received reports that print.alaska.edu is currently experiencing issues. The NTS Technology Support Services and OIT Platforms Applications and Web Services teams are investigating, and we will be making updates at 3-hour intervals.

Thank you for your patience during the resolution of this issue!
Posted Feb 26, 2026 - 14:45 AKST
This incident affected: Other IT Services.