Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2026 - 23:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Mar 25, 2026 - 22:15 AKDT
Scheduled
Network Engineers will be working with GCI to turn up a new internet peering in Juneau. This peering will provide redundancy and resiliency for the entire UA system. There is no expected outage associated with this work, however, the possibility for interruptions do exist while the service is fined-tuned.