Hess Village Planned Power Outage

Incident Report for UAA IT Services

Resolved

UAF Facilities Services has completed work in Hess Village and the impacted network equipment is operating without issue.
Posted Mar 25, 2026 - 16:45 AKDT

Identified

UAF Facility Services has a planned power outage in Hess Village that is impacting network equipment in Hess Village. That power outage is planned to be complete by 1PM.
Posted Mar 25, 2026 - 11:15 AKDT