Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 19:30 AKST
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Jan 22, 2026 - 18:45 AKST
Scheduled
Our BeyondTrust Remote Support server is moving from on-premises to cloud hosting. On Thursday at 7:30pm, the support.alaska.edu instance will be redirected to the external cloud site.
Posted Jan 21, 2026 - 11:15 AKST
This scheduled maintenance affected: Other IT Services.