ELMO Self Service - Degraded Performance

Incident Report for UAA IT Services

Resolved

The UAS ELMO team has resolved the issue with the ELMO. Users should now be able to reset their security questions as normal. Thank you again for your patience during the resolution of this issue!
Posted Nov 30, 2025 - 13:45 AKST

Investigating

We have received reports that users are not able to rest their security questions in ELMO. The UAS ELMO team is currently investigating, and we will be making updates at three (3) hour intervals or as further updates become available.

Thank you for your patience during the resolution of this issue!
Posted Nov 30, 2025 - 13:15 AKST

Update

We have received reports that users are not able to rest their security questions in ELMO. The UAS ELMO team is currently investigating, and we will be making updates at three (3) hour intervals or as further updates become available.

Thank you for your patience during the resolution of this issue!
Posted Nov 30, 2025 - 11:45 AKST

Identified

We have received reports that users are not able to rest their security questions in ELMO. The UAS ELMO team is currently investigating, and we will be making updates at opening 10:00 AM AKST Sunday or as further updates become available.

Thank you for your patience during the resolution of this issue!
Posted Nov 29, 2025 - 18:00 AKST

Investigating

We have received reports that users are not able to rest their security questions in ELMO. The UAS ELMO team is currently investigating, and we will be making updates at three (3) hour intervals.

Thank you for your patience during the resolution of this issue!
Posted Nov 29, 2025 - 15:15 AKST