Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2025 - 19:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Oct 17, 2025 - 18:15 AKDT
Scheduled
The planned work will impact network connectivity (wireless and wired) for the 3rd, 4th, and 5th floors of the UAF Elvey building from 7pm to 10 pm. OIT Network Operations will be upgrading the network access switches of the 3rd and 4th floor communications rooms.