Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 13:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Oct 23, 2025 - 12:15 AKDT
Scheduled
No outage is expected during this change. OIT Security will be implementing an additional email security product to aid in filtering out potentially harmful messages from UA inboxes.
Posted Oct 17, 2025 - 15:15 AKDT
This scheduled maintenance affected: G Suite @ UA (Google Apps Gmail).