Disruption with Course Listings in Continuing Education (Genius)

Incident Report for UAA IT Services

Identified

Update - We have identified the root cause and began implementing the solution for correcting course listings and curated catalog views in Continuing Education (Genius).

Course listing and catalog pages should filter to the expected list for the specific campus or programs.

Learners may need to have an affiliation added to their account if they are not able to see the courses expected or encounter an error when attempting to register from a custom link. This issue is under continued investigation for resolution.

Errors or support requests related to these issues can be emailed to uaa.techsupport@alaska.edu for assistance.
Updates will be posted here as available.
Posted Aug 19, 2026 - 17:13 AKDT

Investigating

We’re currently experiencing a disruption with course listings in Continuing Education (Genius).

UAA IT Services is working to identify the root cause and implement a solution.

Course listing and catalog pages are currently showing courses from across the entire system instead of the expected list for the specific campus or program.

No action is needed on your end. Updates will be posted here as available.
Posted Aug 04, 2026 - 11:21 AKDT
This incident affects: Other IT Services.