Network Outages at Multiple Buildings

Incident Report for UAA IT Services

Update

Network restoration at the Alaska Airlines Center (AAC) is nearly complete, and service is expected to be fully restored within an hour.

Next update at 9:10 A.M., or when new information becomes available.
Posted Jul 08, 2026 - 08:10 AKDT

Update

The estimated restoration time for network service at the Alaska Airlines Center (AAC) has been updated to approximately 5:00 P.M.

Next update at 5:00 P.M., or when new information becomes available.
Posted Jul 07, 2026 - 14:35 AKDT

Identified

We have identified the root cause of the network issue and implemented a fix for the affected buildings.

Network service has been restored to all impacted locations except the Alaska Airlines Center (AAC).

We are actively working to restore connectivity at the AAC and expect service to be restored within approximately two hours.

Next update at 3:00 P.M., or when new information becomes available.
Posted Jul 07, 2026 - 13:15 AKDT

Update

We are continuing to investigate this issue.
Posted Jul 07, 2026 - 11:44 AKDT

Investigating

We’re currently experiencing network outages at multiple buildings, including Health Sciences Building (HSB) and Alaska Airlines Center (AAC).

UAA IT Services is working to identify the root cause and implement a solution.

Users may experience issues connecting to the Wi-Fi, wired network, and campus phones. AAC will be down for a few hours. The main switch died.

Next update at 12:30 A.M., or when new information becomes available.
Posted Jul 07, 2026 - 10:32 AKDT
This incident affects: UAA Network and Telephony.