Southeast Internet Outage & ELMO Slowness

Incident Report for UAA IT Services

Resolved

ACS Reported last night that Southeast Alaska systems are back up and accessible.
Posted Mar 03, 2025 - 07:45 AKST

Update

Internet in Southeast Alaska remains nonfunctional, however ELMO has been rerouted and should now be loading at a regular rate.
ACS has published the following update:

"Technical team has confirmed damage to the ACS subsea cable system connecting Juneau.

We are dispatching a repair ship. We do not yet have an estimated time for restoral.

We are also working to find alternate ways to restore connectivity in Juneau."
Posted Feb 28, 2025 - 15:15 AKST

Update

ACS is extending the maintenance window for their fix to the Juneau/AK Southeast network, and has provided the below update:

"Update: Alaska Communications Emergency Network Maintenance Notification
Please see the amended time listed below:

Maintenance Window: 2/28/2025

Start Time, including time zone: 8:30 AM AKDT, 2/28/2025
Stop time, including time zone: 5:00 PM AKDT, 2/28/2025


We apologize for any inconvenience."

Thanks so much for your time and patience!
Posted Feb 28, 2025 - 11:30 AKST

Update

There is currently a full network outage in Southeast Alaska, originating with the service provider, ACS. Since our ELMO service is hosted there, it is also experiencing slowness.

ACS has reported that they will be performing emergency maintenance shortly with the below timeline and details.

Start Time, including time zone: 08:30 AM AKDT, 2/28/2025
Stop time, including time zone: 12:00 PM AKDT, 2/28/2025

Maintenance Window Duration (hh:mm): 3:30 hr

Number of outages: One.
Times and type: One service interruption of up to 1 hour is anticipated during the maintenance window.
Posted Feb 28, 2025 - 08:30 AKST

Identified

ACS has reported that they will be performing emergency maintenance shortly with the below timeline.

Maintenance Date: 2/28/2025

Start Time, including time zone: 08:30 AM AKDT, 2/28/2025
Stop time, including time zone: 12:00 PM AKDT, 2/28/2025

Maintenance Window Duration (hh:mm): 3:30 hr
Posted Feb 28, 2025 - 08:00 AKST

Investigating

Due to a regional ACS outage in Juneau, users of elmo.alaska.edu may experience long load times. We'll post here as the status changes. Thank you for your patience as ACS works to resolve the issue.
Posted Feb 28, 2025 - 07:30 AKST