Qualtrics Login Issues
Incident Report for UAA IT Services
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 07:35 AKST
Investigating
We have identified an issue with Qualtrics login failures and are working with the vendor to resolve the issue. Thank you for your patience as we look into this.
Posted Jan 13, 2022 - 08:35 AKST
This incident affected: Software & Applications (Qualtrics).