Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 29, 2026 - 00:15 AKDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 29, 2026 - 00:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Jul 28, 2026 - 23:15 AKDT
Scheduled
ACS reports that Copper Valley will be performing emergency network maintenance. This maintenance will include splicing fibers to the new 144 fiber to replace the damaged 96 fiber between Edgerton and Ernestine. One service interruption of up to 2 hours is anticipated during the maintenance window.
This maintenance has been deemed essential and cannot be rescheduled.
UA Network Engineers believe that the redundant circuits should handle the traffic via an alternate path, but some disruptions and slow downs might be noticed.