Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 09:15 AKDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 09:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Oct 20, 2025 - 08:15 AKDT
Scheduled
TEST Banner environment will be refreshed or cloned from data in the production Banner environment to facilitate UA business processes to use this instance for testing and validation of processes. During this event the environment will be unavailable during the duration of the event.