Qualtrics Reports Service Unavailable
Incident Report for UAA IT Services
Resolved
The incident has been resolved.
Posted Jul 22, 2021 - 08:50 AKDT
Investigating
Qualtrics reports Service Unavailable - DNS failure when users navigate to qualtrics.com. UAA IT Services will provide updates as they become available.
Posted Jul 22, 2021 - 08:15 AKDT
This incident affected: Software & Applications (Qualtrics).