Network has been restored at PWSC. Internet and campus phones are now operational.
We apologize for the network inconvenience.
Posted Jan 27, 2026 - 10:54 AKST
Investigating
The Prince William Sound College (PWSC) experiencing an unexpected network outage. The main UAA Anchorage campus and the other UAA community campuses are not affected.
UAA IT Services is working with PWSC to identify the root cause and implement a solution.
Users may experience no internet and campus phone network connection at.
Next update at 9:12 AM.
Posted Jan 27, 2026 - 08:12 AKST
This incident affected: UAA Network and Telephony.