ELMO Outage
Incident Report for UAA IT Services
Resolved
ELMO is currently stable and operational. Thank you for your patience.
Posted Dec 09, 2022 - 08:30 AKST
Monitoring
Technicians have implemented a fix and are currently monitoring the service's stability.
Posted Dec 08, 2022 - 16:00 AKST
Investigating
We are currently investigating reports of ELMO errors impacting logins to the service.
Posted Dec 08, 2022 - 15:30 AKST