Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 05, 2025 - 04:15 AKDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 05, 2025 - 04:00 AKDT
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Apr 05, 2025 - 03:15 AKDT
Scheduled
We need to implement two changes in RPTP that require a database restart. These updates are intended to enhance performance and ensure compatibility with the new NetApp configuration.
Posted Apr 04, 2025 - 17:30 AKDT
This scheduled maintenance affected: Other IT Services.