Foxit Login
Incident Report for UAA IT Services
Resolved
This incident has been resolved. If you are still having issues accessing the application please call the service desk for assistance with Foxit.
Posted Nov 16, 2022 - 10:45 AKST
Monitoring
The License for Foxit has been updated. All Users will now be able to sign into Foxit and activate the new license. You may need to log into Foxit again, to do so please follow these instructions https://alaska.edu/oit/services/software-downloads/licensed-software/foxit/foxit.php. Thank you for your patience during this time.
Posted Nov 14, 2022 - 16:30 AKST
Identified
The UA Foxit License has expired, we are currently working on renewing the license. We do not have time for a resolution yet. Thank you for your patience.
Posted Nov 14, 2022 - 16:15 AKST