Network Outage at MSC, KRC, KBC, and Kodiak College

Incident Report for UAA IT Services

Resolved

Network has been restored at our affected community campuses. Internet and campus phones are now operational.
Posted Jan 20, 2026 - 10:26 AKST

Update

We have received reports that Kachemak Bay Campus (KBC) is now affected by this network outage too.
Posted Jan 20, 2026 - 07:53 AKST

Investigating

We’re currently experiencing a network outage at our UAA community campuses:
- Mat-Su College (MSC)
- Kenai River Campus (KRC)
- Kodiak College

UAA IT Services is working with the vendor and community campuses to identify the root cause and implement a solution.

Users may experience may not able to reach the internet and use campus phones at this time.

Next update at 10:45 AM.
Posted Jan 20, 2026 - 07:43 AKST
This incident affected: UAA Network and Telephony.