The affected components of ELMO appear to be stable. We will continue monitoring the stability of the fix over the weekend, and you can expect a final update at the start of business (8:00AM) Monday if there is no new information until then.
Thank you again for your patience during the resolution of this issue!
Posted May 15, 2026 - 17:00 AKDT
Monitoring
The UAS ELMO team has identified the issue with ELMO service and has implemented a fix, which is being monitored for effectiveness and stability.
Thank you again for your patience during the resolution of this issue! You can expect further updates at the end of the business day (5:00PM) or as new information becomes available.
Posted May 15, 2026 - 15:15 AKDT
Investigating
We have received reports that ELMO is currently experiencing issues. The UAS ELMO team is currently investigating, and we will be making updates at 30 minute intervals.
Thank you for your patience during the resolution of this issue!