Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 06:15 AKST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 06:00 AKST
Update
Maintenance will begin as scheduled in 60 minutes.
Posted Dec 18, 2025 - 05:15 AKST
Scheduled
ACS Will Migrate the Fairbanks to Whittier WAN Circuit to a different fiber path. This work is going to move traffic off of fiber while they perform an emergency outage. A single brief outage will occur during this window, and another will occur at a future date after the work is completed. Future work will involve a separate outage notification when a date and time has been determined.